Discussion:
[SM-USERS] Cannot send email from my Debian server using Squirrelmail.
(too old to reply)
Alf Stockton
2010-06-27 16:16:42 UTC
Permalink
Please tell me what I got wrong when setting up squirrelmail on my debian server.
Configuration looks like:-
SquirrelMail version: 1.5.0
Config file version: 1.4.0
Config file last modified: 27 June 2010 09:14:58
Checking PHP configuration...
PHP version 5.2.0-8+etch16 OK.
PHP extensions OK.
Checking paths...
Data dir OK.
Attachment dir is the same as data dir.
Plugins OK.
Themes OK.
Checking outgoing mail service....
SMTP server OK (220 stockton.co.za ESMTP Sendmail
8.13.8/8.13.8/Debian-3+etch1; Sun, 27 Jun 2010 11:51:51 -0400; (No UCE/UBE)
logging access from: localhost(OK)-localhost [127.0.0.1])
Checking IMAP service....
IMAP server OK (* OK Dovecot ready.)

Congratulations, your SquirrelMail setup looks fine to me!

However for some reason I cannot send emails from squirrelmail.
No error messages and I cannot find where in the logs any messages might appear.
--
---

Regards,
Alf Stockton www.stockton.co.za

To err is human, to forgive canine.
Derek Piazza
2010-06-27 16:46:33 UTC
Permalink
Post by Alf Stockton
Please tell me what I got wrong when setting up squirrelmail on my debian server.
Configuration looks like:-
SquirrelMail version: 1.5.0
Config file version: 1.4.0
Config file last modified: 27 June 2010 09:14:58
Checking PHP configuration...
PHP version 5.2.0-8+etch16 OK.
PHP extensions OK.
Checking paths...
Data dir OK.
Attachment dir is the same as data dir.
Plugins OK.
Themes OK.
Checking outgoing mail service....
SMTP server OK (220 stockton.co.za ESMTP Sendmail
8.13.8/8.13.8/Debian-3+etch1; Sun, 27 Jun 2010 11:51:51 -0400; (No UCE/UBE)
logging access from: localhost(OK)-localhost [127.0.0.1])
Checking IMAP service....
IMAP server OK (* OK Dovecot ready.)
Congratulations, your SquirrelMail setup looks fine to me!
However for some reason I cannot send emails from squirrelmail.
No error messages and I cannot find where in the logs any messages might appear.
What is the error message that you are getting from sendmail when you
try to send email out? There may just be a setting that you are missing.

thanks!
Alf Stockton
2010-06-28 09:34:44 UTC
Permalink
Post by Derek Piazza
Post by Alf Stockton
Please tell me what I got wrong when setting up squirrelmail on my debian server.
Configuration looks like:-
SquirrelMail version: 1.5.0
Config file version: 1.4.0
Config file last modified: 27 June 2010 09:14:58
Checking PHP configuration...
PHP version 5.2.0-8+etch16 OK.
PHP extensions OK.
Checking paths...
Data dir OK.
Attachment dir is the same as data dir.
Plugins OK.
Themes OK.
Checking outgoing mail service....
SMTP server OK (220 stockton.co.za ESMTP Sendmail
8.13.8/8.13.8/Debian-3+etch1; Sun, 27 Jun 2010 11:51:51 -0400; (No UCE/UBE)
logging access from: localhost(OK)-localhost [127.0.0.1])
Checking IMAP service....
IMAP server OK (* OK Dovecot ready.)
Congratulations, your SquirrelMail setup looks fine to me!
However for some reason I cannot send emails from squirrelmail.
No error messages and I cannot find where in the logs any messages might appear.
What is the error message that you are getting from sendmail when you
try to send email out? There may just be a setting that you are missing.
There is no error from sendmail and in fact if I sent email from my web
page(www.stockton.co.za) the email get delivered fine.
--
---

Regards,
Alf Stockton www.stockton.co.za

To err is human, to forgive canine.
Tomas Kuliavas
2010-06-28 09:46:10 UTC
Permalink
Post by Alf Stockton
Post by Derek Piazza
Post by Alf Stockton
Please tell me what I got wrong when setting up squirrelmail on my debian server.
Configuration looks like:-
SquirrelMail version: 1.5.0
PHP version 5.2.0-8+etch16 OK.
...
Post by Alf Stockton
Post by Derek Piazza
Post by Alf Stockton
However for some reason I cannot send emails from squirrelmail.
No error messages and I cannot find where in the logs any messages might appear.
What is the error message that you are getting from sendmail when you
try to send email out? There may just be a setting that you are missing.
There is no error from sendmail and in fact if I sent email from my web
page(www.stockton.co.za) the email get delivered fine.
SquirrelMail 1.5.0 was released before PHP 5.2.0. In PHP 5.1.0-5.1.2 some
very specific language construct was modified or fixed. SquirrelMail 1.5.0
used that construct. Result is "SM 1.5.0" + "PHP 5.1+" = "can't send
emails"

Debian made a mistake by packaging devel version of SquirrelMail. If you
use SquirrelMail package created by Debian, get SquirrelMail packages from
newer Debian version or make sure that you don't have outdated package
version. Debian Etch should have 2:1.4.9a-5
--
Tomas
Alf Stockton
2010-06-28 12:02:46 UTC
Permalink
Post by Tomas Kuliavas
Post by Alf Stockton
Post by Derek Piazza
Post by Alf Stockton
Please tell me what I got wrong when setting up squirrelmail on my debian server.
Configuration looks like:-
SquirrelMail version: 1.5.0
PHP version 5.2.0-8+etch16 OK.
...
Post by Alf Stockton
Post by Derek Piazza
Post by Alf Stockton
However for some reason I cannot send emails from squirrelmail.
No error messages and I cannot find where in the logs any messages might appear.
What is the error message that you are getting from sendmail when you
try to send email out? There may just be a setting that you are missing.
There is no error from sendmail and in fact if I sent email from my web
page(www.stockton.co.za) the email get delivered fine.
SquirrelMail 1.5.0 was released before PHP 5.2.0. In PHP 5.1.0-5.1.2 some
very specific language construct was modified or fixed. SquirrelMail 1.5.0
used that construct. Result is "SM 1.5.0" + "PHP 5.1+" = "can't send
emails"
Debian made a mistake by packaging devel version of SquirrelMail. If you
use SquirrelMail package created by Debian, get SquirrelMail packages from
newer Debian version or make sure that you don't have outdated package
version. Debian Etch should have 2:1.4.9a-5
Thank you all and I am now attempting the install and configuration of 2:1.4.9a-5.
--
---

Regards,
Alf Stockton www.stockton.co.za

To err is human, to forgive canine.
Alf Stockton
2010-06-28 12:35:12 UTC
Permalink
Post by Alf Stockton
Post by Tomas Kuliavas
Post by Alf Stockton
Post by Derek Piazza
Post by Alf Stockton
Please tell me what I got wrong when setting up squirrelmail on my debian server.
Configuration looks like:-
SquirrelMail version: 1.5.0
PHP version 5.2.0-8+etch16 OK.
...
Post by Alf Stockton
Post by Derek Piazza
Post by Alf Stockton
However for some reason I cannot send emails from squirrelmail.
No error messages and I cannot find where in the logs any messages might appear.
What is the error message that you are getting from sendmail when you
try to send email out? There may just be a setting that you are missing.
There is no error from sendmail and in fact if I sent email from my web
page(www.stockton.co.za) the email get delivered fine.
SquirrelMail 1.5.0 was released before PHP 5.2.0. In PHP 5.1.0-5.1.2 some
very specific language construct was modified or fixed. SquirrelMail 1.5.0
used that construct. Result is "SM 1.5.0" + "PHP 5.1+" = "can't send
emails"
Debian made a mistake by packaging devel version of SquirrelMail. If you
use SquirrelMail package created by Debian, get SquirrelMail packages from
newer Debian version or make sure that you don't have outdated package
version. Debian Etch should have 2:1.4.9a-5
Thank you all and I am now attempting the install and configuration of 2:1.4.9a-5.
I now believe that I have 2:1.4.9a-5 installed (see
www.stockton.co.za/squirrelmail) and running but I still cannot send email
from squirrelmail.
--
---

Regards,
Alf Stockton www.stockton.co.za

To err is human, to forgive canine.
Tomas Kuliavas
2010-06-28 14:40:52 UTC
Permalink
Post by Alf Stockton
I now believe that I have 2:1.4.9a-5 installed (see
www.stockton.co.za/squirrelmail) and running but I still cannot send email
from squirrelmail.
OK. Now that we eliminated SquirrelMail 1.5.0 issues with newer PHP
version, lets continue.

Could you show your SquirrelMail configuration.

Run 'squirrelmail-configure' on your server

select 2 for "Server Settings", select B for "Update SMTP or Sendmail
Settings"

Show configuration options from 4 to 8.

When you send emails, what kind of error you see in SquirrelMail? "Cannot
send emails" does not explain why you think that you can't send emails.

If your website application can send emails and it is PHP based,
application uses standard PHP mail() function. SquirrelMail does not do
that. SquirrelMail uses local SMTP service by default. It must be
reconfigured in order to send through /usr/sbin/sendmail like mail()
function does and even then SquirrelMail can hit restrictions that don't
apply to mail().
--
Tomas
Paul Lesniewski
2010-06-27 18:41:33 UTC
Permalink
Post by Alf Stockton
Please tell me what I got wrong when setting up squirrelmail on my debian server.
Configuration looks like:-
SquirrelMail version: 1.5.0
DO NOT use this version! Please download a snapshot of version 1.5.2
and use it instead.
Post by Alf Stockton
Config file version: 1.4.0
Config file last modified: 27 June 2010 09:14:58
Checking PHP configuration...
    PHP version 5.2.0-8+etch16 OK.
    PHP extensions OK.
Checking paths...
    Data dir OK.
    Attachment dir is the same as data dir.
    Plugins OK.
    Themes OK.
Checking outgoing mail service....
    SMTP server OK (220 stockton.co.za ESMTP Sendmail
8.13.8/8.13.8/Debian-3+etch1; Sun, 27 Jun 2010 11:51:51 -0400; (No UCE/UBE)
logging access from: localhost(OK)-localhost [127.0.0.1])
Checking IMAP service....
    IMAP server OK (* OK Dovecot ready.)
Congratulations, your SquirrelMail setup looks fine to me!
However for some reason I cannot send emails from squirrelmail.
No error messages and I cannot find where in the logs any messages might appear.
You can get any PHP errors to show by using the settings explained on
the following page, but I suspect the errors are not PHP, so this
probably won't help:

http://squirrelmail.org/docs/admin/admin-11.html#ss11.1

Note that PHP errors might already be getting logged in your web
server log file. You should check it.

Probably the more informative place to look is in your mail server log
file. Usually, that's /var/log/maillog which tells you about what
happened to the message when SquirrelMail handed it to the SMTP
server. However, this all assumes that you are pointing SquirrelMail
to a SMTP server that is local - on the same machine as SquirrelMail
is. If not, check the log files on the machine where the SMTP server
resides.
--
Paul Lesniewski
SquirrelMail Team
Please support Open Source Software by donating to SquirrelMail!
http://squirrelmail.org/donate_paul_lesniewski.php
mick crane
2010-06-27 19:53:36 UTC
Permalink
Post by Alf Stockton
Please tell me what I got wrong when setting up squirrelmail on my
debian server. Configuration looks like:-
SquirrelMail version: 1.5.0
I do not know if this is helpful but if you are sending through your isp's
smtp server it's possible that you have to authenticate sending addresses
with them. I had this issue but they should tell you if that is what is
happening.
Alf Stockton
2010-06-28 09:31:16 UTC
Permalink
Post by mick crane
Post by Alf Stockton
Please tell me what I got wrong when setting up squirrelmail on my
debian server. Configuration looks like:-
SquirrelMail version: 1.5.0
I do not know if this is helpful but if you are sending through your isp's
smtp server it's possible that you have to authenticate sending addresses
with them. I had this issue but they should tell you if that is what is
happening.
I am the ISP and have already logged on.
--
---

Regards,
Alf Stockton www.stockton.co.za

To err is human, to forgive canine.
Tomas Kuliavas
2010-06-27 20:02:03 UTC
Permalink
Post by Alf Stockton
Please tell me what I got wrong when setting up squirrelmail on my debian server.
Configuration looks like:-
SquirrelMail version: 1.5.0
Config file version: 1.4.0
Config file last modified: 27 June 2010 09:14:58
Checking PHP configuration...
PHP version 5.2.0-8+etch16 OK.
PHP extensions OK.
Checking paths...
Data dir OK.
Attachment dir is the same as data dir.
Plugins OK.
Themes OK.
Checking outgoing mail service....
SMTP server OK (220 stockton.co.za ESMTP Sendmail
8.13.8/8.13.8/Debian-3+etch1; Sun, 27 Jun 2010 11:51:51 -0400; (No UCE/UBE)
logging access from: localhost(OK)-localhost [127.0.0.1])
Checking IMAP service....
IMAP server OK (* OK Dovecot ready.)
Congratulations, your SquirrelMail setup looks fine to me!
However for some reason I cannot send emails from squirrelmail.
No error messages and I cannot find where in the logs any messages might appear.
Go to http://www.squirrelmail.org/wiki/KnownBugs and scroll to the bottom of
the page. Read chapter about sqimap_append.
--
View this message in context: http://old.nabble.com/Cannot-send-email-from-my-Debian-server-using-Squirrelmail.-tp29006542p29007646.html
Sent from the squirrelmail-users mailing list archive at Nabble.com.
d***@hotmallo.com
2010-06-27 21:42:00 UTC
Permalink
-----Original Message-----

From: Tomas Kuliavas <***@users.sourceforge.net>
Subj: Re: [SM-USERS] Cannot send email from my Debian server using Squirrelmail.
Date: Sun Jun 27, 2010 1:02 pm
Size: 1K
Post by Alf Stockton
Please tell me what I got wrong when setting up squirrelmail on my debian
server.
Configuration looks like:-
SquirrelMail version: 1.5.0
Config file version: 1.4.0
Config file last modified: 27 June 2010 09:14:58
Checking PHP configuration...
PHP version 5.2.0-8+etch16 OK.
PHP extensions OK.
Checking paths...
Data dir OK.
Attachment dir is the same as data dir.
Plugins OK.
Themes OK.
Checking outgoing mail service....
SMTP server OK (220 stockton.co.za ESMTP Sendmail
8.13.8/8.13.8/Debian-3+etch1; Sun, 27 Jun 2010 11:51:51 -0400; (No
UCE/UBE)
logging access from: localhost(OK)-localhost [127.0.0.1])
Checking IMAP service....
IMAP server OK (* OK Dovecot ready.)
Congratulations, your SquirrelMail setup looks fine to me!
However for some reason I cannot send emails from squirrelmail.
No error messages and I cannot find where in the logs any messages might
appear.
Go to http://www.squirrelmail.org/wiki/KnownBugs and scroll to the bottom of
the page. Read chapter about sqimap_append.

good to know!
--
View this message in context: http://old.nabble.com/Cannot-send-email-from-my-Debian-server-using-Squirrelmail.-tp29006542p29007646.html
Sent from the squirrelmail-users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
-----
squirrelmail-users mailing list
Posting guidelines: http://squirrelmail.org/postingguidelines
List address: squirrelmail-***@lists.sourceforge.net
List archives: http://news.gmane.org/gmane.mail.squirrelmail.user
List info (subscribe/unsubscribe/change options): https://lists.sourceforge.net/lists/listinfo/squirrelmail-users
Continue reading on narkive:
Loading...